• 中文
    • English
  • 注册
  • 查看作者
  • 打开eclipse时显示“Failed to load the JNI shared library”错误

    问题原因

    该问题的原因通常是我们eclipse的位数和JDK的位数不一致导致的,比如Eclipse是64位JDK却是32位

    解决方法:只要将eclipse和jdk换成相同位数便可以解决

    那么我们如何才能知道自己的eclipse和jdk的位数是多少呢?首先我们查看JDK的位数,打开cmd,输入

    java -version

    我们可以查看到安装的是64位的JDK

    打开eclipse时显示“Failed to load the JNI shared library”错误

    我们接着查看eclipse的位置,首先找的eclipse的安装目录,打开eclipse.ini文件

    打开eclipse时显示“Failed to load the JNI shared library”错误

    找到如下内容: 

    32位: plugins/org.eclipse.equinox.launcher.win32.**win32.x86_*************——-表示32位的

    64位: plugins/org.eclipse.equinox.launcher.win32.**win32.x86_64***********——-表示64位

    通过下图可以看到,我们的eclipse是64位的,如果通过下图发现你的JDK和eclipse位数不相同,则替换成相同的即可解决问题。

    打开eclipse时显示“Failed to load the JNI shared library”错误

  • 0
  • 0
  • 0
  • 2.6k
  • 请登录之后再进行评论

    登录

    赞助本站

    • 支付宝
    • 微信
    • QQ

    感谢一直支持本站的所有人!

    单栏布局 侧栏位置: